Get in touch
Back
Downtime

Some services are down

Started 31 Oct at 01:01pm EET, resolved 31 Oct at 01:30pm EET.

Mestamaster Servers
Resolved

The issues have been mitigated, and all Mestamaster services are now available.

Posted 31 Oct at 01:30pm EET.
Created

We have identified an issue, and mestamaster service has been impacted. We are investigating

Posted 31 Oct at 01:01pm EET.