Get in touch
Back
Maintenance

Updating DNS records of Mestamaster

Completed 17 Dec at 08:00pm EET.

Mestamaster App
Completed

Maintenance completed

Posted 17 Dec at 08:00pm EET.
Started

The Mestamaster web app might become unavailable for a few minutes, or show "This site is insecure" message while we update our certificates. Mobile app is not affected.

Posted 17 Dec at 04:00pm EET.