Get in touch
Back
Maintenance

DNS records update

Completed 1 Jun at 05:00pm EEST.

Mestamaster App
Completed

Maintenance completed

Posted 1 Jun at 05:00pm EEST.
Started

We are currently updating our DNS names. app.mestamaster.com will now have the new mestamaster version. .fi and .io domains will be standardised to .com domains with redirects.

Posted 1 Jun at 03:00pm EEST.